$re = '/(?m)^(.+?)-(\w+)$/u';
$str = 'Example A:
Input:
something-E123
Example B:
Input:
some-text-EABC
Example C:
Input:
something-something-moretext-EA1A
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);