using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b-";
string substitution = @"\n";
string input = @"Description 2--340-20
-2
-2---2---3-
@#$-@$#-@#$-";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}