$re = '/<\/?a ?([^>]+)?>/m';
$str = '<a href="http://hello.com/">Link text</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);