package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Action\s*\d*\s*:[\s]*(.*?)[\s]*Action\s*\d*\s*Input\s*\d*\s*:[\s]*(.*)`)
var str = `I can use the \`ls\` command to list the contents of the directory and \`grep\` to search for the specific file.
Action:
Terminal
Action Input:
ls -l ~/.bashrc.d/
Action\s*\d*\s*:[\s]*(.*?)\nAction\s*\d*\s*Input\s*\d*\s*:[\s]*(.*)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}