// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"^(?<x_forwarded_for>(?:[0-9:.-]*, )?(?<clientip>[0-9:.-]*)) (?<ident>[^ ]*) (?<auth>[^ ]*) \[(?<time>[^\]]*)\] "(?<verb>\S+)(?: +(?<request>[^\"]*?)(?: +(?<httpversion>\S*))?)?" (?<response>[^ ]*) (?<bytes>[^ ]*) "(?<referer>[^\"]*)" "(?<agent>[^\"]*)" "(?<request_time>[^\"]*)" "(?<host>[^\"]*)(?::(?<host_port>\S+))?"(?: ATI:"(?<amazn_trace_id>[^\"]*)")?(?: "(?<hdr_location>[^\"]*)" "(?<request_length>[^\"]*)")?(?: "(?<tls_version>[^\/]*)\/(?<tls_cipher>[^\"]*)")?(?: trace_id:"(?<a0_request_id>[^\"]*)")?$"#).unwrap();
let string = "- - - [15/Jan/2020:15:05:36 +0000] \"GET / HTTP/1.1\" 200 14 \"-\" \"curl/7.54.0\" \"0.000\" \"localhost:8888\" ATI:\"-\" \"-\" \"78\" \"-/-\" trace_id:\"6-1579100736.791-172.17.0.1-78\"";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}