re = /^(?:(?:-?(?:[1-9]\d*)?)|0)$/m
str = 'OK:
-
-10
-54
66
0
1
NOK:
+
+1
-010
010'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end