// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?:-?(?:[1-9]\d*)?)|0)$").unwrap();
let string = "OK:
-
-10
-54
66
0
1
NOK:
+
+1
-010
010";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}