const regex = new RegExp('I have created .* number <b>REQUK[0-9]{9,11}</b>.Before you ask me anything else I would like you provide some feedback on the topic just discussed.How did you enjoy this conversation with me?', 'gm')
const str = `I have created a incident with your request. This is your incident number <b>REQUK0005652859</b>.Before you ask me anything else I would like you provide some feedback on the topic just discussed.How did you enjoy this conversation with me?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}