package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)case_when\([^(]*%in%(*SKIP)(*FAIL)|[^(]*%in%`)
var str = `a %in% c('b', 'e')
case_when(a %in% c('b', 'e'))
hello`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}