using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\+(?<code>\d))?(?<number>\d+)$";
string input = @"+718341233124
+118341233124
518341233124
d718341233124
+71834123adg3124
7-18341233124
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}