$re = '/^(?:\+(?<code>\d))?(?<number>\d+)$/m';
$str = '+718341233124
+118341233124
518341233124
d718341233124
+71834123adg3124
7-18341233124
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);