// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\+(?<code>\d))?(?<number>\d+)$").unwrap();
let string = "+718341233124
+118341233124
518341233124
d718341233124
+71834123adg3124
7-18341233124
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}