package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\p{Cyrillic}`)
var str = `a b c d Б В Г Д`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}