package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\B#)?\w+(?:-\w+)*`)
var str = `Test a#words 100-200-300
Test #words 100-200-300
Test ##words 100-200-300`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}