use strict;
my $str = '[dailyml place=“Here” year=“2023” month=“03” day=“13” time=“12:34”]';
my $regex = qr/\[dailyml place=“(.+)” year=“(\d\d\d\d)” month=“(\d\d)” day=“(\d\d)” time=“(\d\d):(\d\d)”\]/mp;
my $subst = '[dailyml place=“$1” year=“$2” month=“($3” day=“13” time=“12:34”]\\n\\n—TAGS—';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";