import Foundation
let pattern = #"\[dailyml place=“(.+)” year=“(\d\d\d\d)” month=“(\d\d)” day=“(\d\d)” time=“(\d\d):(\d\d)”\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[dailyml place=“Here” year=“2023” month=“03” day=“13” time=“12:34”]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[dailyml place=“$1” year=“$2” month=“($3” day=“13” time=“12:34”]\n\n—TAGS—"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)