$re = '/Text[\s.][0-9]*(?![-\d])/m';
$str = 'Text 52-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);