import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "yt(?<ytVer>[a-z])(?<ytID>[a-zA-Z0-9-_]{8,11})";
final String string = "https://www.youtube.com/watch?v=f7dWJcJgEjE?list\n"
+ "https://youtu.be/voceyAq-R9E\n"
+ "https://www.youtube.com/embed/f7dWJcJgEjE\n"
+ "https://youtu.be/watch?v=DKbQFMOEFTs\n\n"
+ "ytaDKbQFMOEFTs\n"
+ "ytzvoceyAq-R9E\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}