package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[ \t]*\/\/.*\r?\n|[ \t]*\/\/.*`)
var str = `// this is awesome code
const a =1
// this is nice
const b = 2 // oh great
// with some indentation
const x = 99`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}