re = /^[ \t]*\/\/.*\r?\n|[ \t]*\/\/.*/m
str = '// this is awesome code
const a =1
// this is nice
const b = 2 // oh great
// with some indentation
const x = 99'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result