const regex = /^(?<latitude>[N|S]\d+)(?<longtitude>[E|W]\d+),(?<einsatznr>\d+),(?<beschreibung>(.+))\s(?<ort1>.*?),\s(?<strasse1>.*?),\s#(?<strasse2>.*?)\s(?<ort2>.*?),\s(?<gemeinde>.*?),(?<textmeldung>.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<latitude>[N|S]\\d+)(?<longtitude>[E|W]\\d+),(?<einsatznr>\\d+),(?<beschreibung>(.+))\\s(?<ort1>.*?),\\s(?<strasse1>.*?),\\s#(?<strasse2>.*?)\\s(?<ort2>.*?),\\s(?<gemeinde>.*?),(?<textmeldung>.*)', 'gm')
const str = `11.11.1111 22:22:22, 12345 Container - B1 mSoSi, Straße NRx Ort Gemeinde, Textmeldung
N12345678E12345678,12345,Beschreibung Ort, Straße, #Straße Ort, Gemeinde,Textmeldung`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}