# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<latitude>[N|S]\d+)(?<longtitude>[E|W]\d+),(?<einsatznr>\d+),(?<beschreibung>(.+))\s(?<ort1>.*?),\s(?<strasse1>.*?),\s#(?<strasse2>.*?)\s(?<ort2>.*?),\s(?<gemeinde>.*?),(?<textmeldung>.*)"
test_str = ("11.11.1111 22:22:22, 12345 Container - B1 mSoSi, Straße NRx Ort Gemeinde, Textmeldung\n\n"
"N12345678E12345678,12345,Beschreibung Ort, Straße, #Straße Ort, Gemeinde,Textmeldung")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.