const regex = /(?<=")[\w\s]+(?=")\b|\w+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=")[\\w\\s]+(?=")\\b|\\w+', 'g')
const str = `"texto0 texto1 texto2" texto3 "texto4"
texto1 texto2 "texto3 texto4" texto5
"texto0 texto1 texto2" texto3 "texto4"
"texto0 texto1" texto2
texto0 texto1 "texto2 texto3"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}