re = /<item>[\s\S]*?<sub>(.*?)<\/sub>((?!<sub>)[\s\S])*<\/item>/
str = '<item> fffffffffffff
<sub>aaaa</sub>
<value>111</value>
</item>
<item>
<sub>eeee</sub> arg34ddddddddddddddd
<atag>ddd</atag>
<sub>aaaa</sub>
<value>222</value>
</item>
<item>
<sub>eeee</sub> arg34ddddddddddddddd
<atag>ddd</atag>
<sub>aaaa</sub>
</item>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end