package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d{2,3},)+(\d{2,3}),?$|^\d{2,3}$`)
var str = `//pass
12,123,56,567,789,11
12,123,56,567,789,11,
12
123
//fail
12,123,56,567,789,11a
a12,123,56,567,789,11
12,123,56,567,789,1
1,123,56,567,789,11
1234,123,56,567,789,11
12,123,56,567,789,1123
1
1234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}