#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\bdub(s|bed|bing)?\b"
Local $sString = "Movie.Title.2023.2160p.BluRay.HEVC.DV.TrueHD.Atmos.7.1 [Dubbing PL]-GROUP.mkv" & @CRLF & _
"Movie.Title.2023.2160p.BluRay.HEVC.DV.TrueHD.Atmos.7.1 [Eng, Rus, PL Dubs]-GROUP.mkv"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")