using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^===============\n[^=]*^Game friends:\n^- (?:\d|1\d)\n";
string input = @"===============
celine.denecke@gmx.de:x1xc2xx1
Games:
- Summoners War: Sky Arena
- Dragon Blaze
Game friends:
- 68
===============
celine.denecke@gmx.de:x1xc2xx1
Games:
- Summoners War: Sky Arena
- Dragon Blaze
Game friends:
- 18
===============
celine.denecke@gmx.de:x1xc2xx1
Games:
- Summoners War: Sky Arena
- Dragon Blaze
Game friends:
- 68
===============
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}