re = /^===============\n[^=]*^Game friends:\n^- (?:\d|1\d)\n/m
str = '===============
celine.denecke@gmx.de:x1xc2xx1
Games:
- Summoners War: Sky Arena
- Dragon Blaze
Game friends:
- 68
===============
celine.denecke@gmx.de:x1xc2xx1
Games:
- Summoners War: Sky Arena
- Dragon Blaze
Game friends:
- 18
===============
celine.denecke@gmx.de:x1xc2xx1
Games:
- Summoners War: Sky Arena
- Dragon Blaze
Game friends:
- 68
===============
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end