import Foundation
let pattern = #"\b(ALLEE|ANSE|AVENUE|BOULEVARD|CARREFOUR|CHAUSSEE|CHEMIN|CITE|CLOS|COTE|COUR|COURS|DEGRE|DESCENTE|DREVE|ESCOUSSIERE|ESPLANADE|GAFFE|GRAND-ROUTE|IMPASSE|LIAISON|MAIL|MONTEE|PASSAGE|PLACE|PLACETTE|PONT|PROMENADE|QUAI|RESIDENCE|RANG|RAMPE|ROND-POINT|ROUTE|RUE|RUELLE|SENTE|SENTIER|SQUARE|TRABOULE|TRAVERSE|VENELLE|VILLA|VOIE|BERGE|DIGUE|CUL-DE-SAC|ESCALIER|GIRATOIRE|JARDIN|PARVIS|PASSERELLE)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"ALLEE RUE "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)