import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\baddresses: \\[\\d\\.\\d\\.\\d\\.\\d(?:,\\d\\.\\d\\.\\d\\.\\d)*]";
final String string = "version: 2\n"
+ " renderer: networkd\n"
+ " ethernets:\n"
+ " enp0s3:\n"
+ " dhcp4: no\n"
+ " addresses: [192.168.1.222/24]\n"
+ " gateway4: 192.168.1.1\n"
+ " nameservers:\n"
+ " addresses: [8.8.8.8,8.8.4.4]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}