use strict;
my $str = 'Hello, I\'m your \\||spoiler\\|| and another one \\||spoiler2\\||
';
my $regex = qr/\\\|\|(.*?)\\\|\|/mp;
my $subst = 'SPOILER: $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";