$re = '/^[actgACTG]+$/m';
$str = 'ATGGCAAT
atg
AATG!4
this input contains all the char but is in the wrong format';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);