// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^<p>(.*)</p>$").unwrap();
let string = "<p><p>{'Area': 'Square',</p>\\n<p> <tr> <td>'Flag': 'com'}</p></p>";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}