#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{2}:\d{2})"
Local $sString = "*Линия - 1*" & @CRLF & _
"Славянска 07:00 - Кремък 07:30 ;" & @CRLF & _
"Славянска 08:00 - Кремък 08:30 ;" & @CRLF & _
"Славянска 09:00 - Кремък 09:30 ;" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")