import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{2}:\\d{2})";
final String string = "*Линия - 1*\n"
+ "Славянска 07:00 - Кремък 07:30 ;\n"
+ "Славянска 08:00 - Кремък 08:30 ;\n"
+ "Славянска 09:00 - Кремък 09:30 ;\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}