#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([0-9]+)\s([A-Za-z0-9\-\s]+)\,\s([A-Za-z\s]+)\,\s([A-Z]{2})\s([0-9\-]{5,10})"
Local $sString = "123 Riverview Pkwy, Orlando, FL 55556" & @CRLF & _
"12 Street Pkwy, Miami, FL 98989" & @CRLF & _
"18 Street Pkwy, TAMPA, FL 80148-0980" & @CRLF & _
"18 Street 76 PKWY, TAMPA, FL 80148-0980" & @CRLF & _
"18 Goerge-Washington Street 76 Pkwy, Tampa, FL 80148-0980" & @CRLF & _
"18 Street Pkwy, Tampa, FL 80148-0980989"
Local $sSubst = "$2 $3 $4 $5"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)