#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?:(?:http|https):\/\/)?(?:www.)?(?:instagram.com|instagr.am|instagr.com)\/(\w+)"
Local $sString = "http://instagram.com/username" & @CRLF & _
"http://instagram.com/username?modal=true" & @CRLF & _
"" & @CRLF & _
"https://instagram.com/username" & @CRLF & _
"https://instagram.com/username?modal=true" & @CRLF & _
"" & @CRLF & _
"http://www.instagram.com/username" & @CRLF & _
"http://www.instagram.com/username?modal=true" & @CRLF & _
"" & @CRLF & _
"https://www.instagram.com/username" & @CRLF & _
"https://www.instagram.com/username?modal=true" & @CRLF & _
"" & @CRLF & _
"instagram.com/username" & @CRLF & _
"instagram.com/username?modal=true" & @CRLF & _
"" & @CRLF & _
"www.instagram.com/username" & @CRLF & _
"www.instagram.com/username?modal=true" & @CRLF & _
"" & @CRLF & _
"http://instagr.am/username" & @CRLF & _
"http://instagr.am/username?modal=true" & @CRLF & _
"http://www.instagr.am/username" & @CRLF & _
"http://www.instagr.am/username?modal=true" & @CRLF & _
"" & @CRLF & _
"https://instagr.am/username" & @CRLF & _
"https://instagr.com/username" & @CRLF & _
"https://instagr.am/username?modal=true" & @CRLF & _
"https://www.instagr.am/username" & @CRLF & _
"https://www.instagr.am/username?modal=true"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")