import Foundation
let pattern = #"(?:(?:http|https):\/\/)?(?:www.)?(?:instagram.com|instagr.am|instagr.com)\/(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
http://instagram.com/username
http://instagram.com/username?modal=true
https://instagram.com/username
https://instagram.com/username?modal=true
http://www.instagram.com/username
http://www.instagram.com/username?modal=true
https://www.instagram.com/username
https://www.instagram.com/username?modal=true
instagram.com/username
instagram.com/username?modal=true
www.instagram.com/username
www.instagram.com/username?modal=true
http://instagr.am/username
http://instagr.am/username?modal=true
http://www.instagr.am/username
http://www.instagr.am/username?modal=true
https://instagr.am/username
https://instagr.com/username
https://instagr.am/username?modal=true
https://www.instagr.am/username
https://www.instagr.am/username?modal=true
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)