const regex = /^[a-z0-9](-?[a-z0-9])*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z0-9](-?[a-z0-9])*$', 'gmi')
const str = `login
lo-gin
Log23gin
log2-3gin
L--login
L--lo--gin
L---login
---login
login-
login--`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}