#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:\w+)(?:\[(?:\d*|'[^']*')\])?=[\w%]*(?:&|$))*$"
Local $sString = "hello=value&am=i" & @CRLF & _
"hellp" & @CRLF & _
"help=me" & @CRLF & _
"pleas=help&me=plz&var[]=true" & @CRLF & _
"pleas=&me=&var[]=" & @CRLF & _
"helo&ewepcmwep&lalal=true" & @CRLF & _
"pleas=help&me=plz&var[]=true&var[2]=false&var['blahblah']=ipsum"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")