import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:\\w+)(?:\\[(?:\\d*|'[^']*')\\])?=[\\w%]*(?:&|$))*$";
final String string = "hello=value&am=i\n"
+ "hellp\n"
+ "help=me\n"
+ "pleas=help&me=plz&var[]=true\n"
+ "pleas=&me=&var[]=\n"
+ "helo&ewepcmwep&lalal=true\n"
+ "pleas=help&me=plz&var[]=true&var[2]=false&var['blahblah']=ipsum";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}