$re = '/^(?:(?:\w+)(?:\[(?:\d*|\'[^\']*\')\])?=[\w%]*(?:&|$))*$/m';
$str = 'hello=value&am=i
hellp
help=me
pleas=help&me=plz&var[]=true
pleas=&me=&var[]=
helo&ewepcmwep&lalal=true
pleas=help&me=plz&var[]=true&var[2]=false&var[\'blahblah\']=ipsum';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);