#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:north|south)?(?:east|west)?\b"
Local $sString = "The westerly barn is a room. The field is east of the barn. The stable is northeast of the field. The forest is northwest of the field." & @CRLF & _
"" & @CRLF & _
"It matches north, south, east, west, northeast, northwest, southeast, southwest and many many empty strings."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")