// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?:north|south)?(?:east|west)?\b").unwrap();
let string = "The westerly barn is a room. The field is east of the barn. The stable is northeast of the field. The forest is northwest of the field.
It matches north, south, east, west, northeast, northwest, southeast, southwest and many many empty strings.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}