re = /([A-Z]{1,9}-[0-9]{2,4}\s:?)|([0-9]{0,2}_.*-[0-9]{0,2}_)/m
str = 'GQSD-65 : title
GQSD-65 title
01_Définitions-04_'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end