import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"public\s+(.+):([^,]+),?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
public typeface:Typeface,
public weight:FontWeight,
public color:Color,
public size:Units,
public line:Units,
public character:Units,
public fontStyle:ABoolean,
public decorationUnderline:ABoolean,
public decorationCrossed:ABoolean,
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"@prop\n\t\tpublic $1:$2;\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)