re = /#+(?:.*?)\KWith Space/m
str = '#ThisIsaHashtagWith Space
With Space'
subst = 'WithSpace'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result