using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:(?!\1)()|\1 )(?:(?!\2)()fat|(?!\3)()cat)){2}";
string input = @"My fat cat is sleeping.
My cat is lazy.
My aunt is fat.
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}