using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^| )hoi($| )|(^| )hallo($| )|(^| )ok($| )|(^| )doei($| )";
string input = @"ik zag hem en toen zei hij hallo
hoi hoe is het
het is ok blijkbaar
doei
twee hallos werkt niet
hhhhoi stotterde hij
doeiii";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}