# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<ref name=\"?((?:[^\">\/]|\/(?!>))*?)\"? *\/?>"
test_str = ("<ref name=Test1/>\n"
"<ref name=Test2 />\n"
"<ref name=\"Test3\"/>\n"
"<ref name=\"Test4\" />\n"
"<ref name=Test5>Foo</ref>\n"
"<ref name=\"Test6\">Foo</ref>\n"
"<ref name=Te/st7/>\n"
"<ref name=Te/st8 />\n"
"<ref name=\"Te/st9\"/>\n"
"<ref name=\"Te/st10\" />\n"
"<ref name=Te/st11>Foo</ref>\n"
"<ref name=\"Te/st12\">Foo</ref>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.